Ubuntu 16.04 fresh install, no internet (Ethernet)

by Lara Larsen   Last Updated July 12, 2019 08:02 AM

I installed a fresh Ubuntu beside Windows 10. In Windows, I have Internet access by ethernet. In Ubuntu, I can see a Wired Connection 1, but without internet access. I am behind a local network.

Ubuntu 16.04.6 LTS

Here are the outcomes of some commands:

ifconfig

sudo lshw -C network

sudo gedit /etc/NetworkManager/NetworkManager.conf

sudo gedit /etc/network/interfaces

I have tried to set interfaces to:

auto enp0s31f6
iface enp0s31f6 inet auto

and then restart the network manager/ reboot, but it didn't work. If fact, as soon as the restart occured, the enp0s31f6 interface was not shown in ifconfig. Any help is appreciated, thanks.

EDIT: Normal internet connection, via USB tethering



Answers 1


In order for tethering to work, make sure you have the following completed...

  • Installed ADB drivers if using a 3rd party application
  • Enabled ADB Debugging via Android Settings if using 3rd party app
  • Installed communication drivers for your specific phone or android
  • MTP drivers installed on both devices and MTP is enabled on your android
  • Check if your android requires a data connection or wifi connection

It'd be helpful if you provided what application you were using or if your using settings, as well as what phone you are using to tether.

ShadowPauler
ShadowPauler
July 12, 2019 07:58 AM

Related Questions


Updated April 20, 2015 22:00 PM

Updated February 23, 2016 03:01 AM

Updated April 18, 2017 07:02 AM

Updated September 03, 2015 19:01 PM

Updated October 10, 2015 16:01 PM